Sie sind nicht angemeldet.

$@ncho

Schüler

  • »$@ncho« ist der Autor dieses Themas

Beiträge: 123

Rechnerkonfiguration: AMD 3500+ @4100+ 2GB Corsair RAM 400er Blue Orb Lüfter

  • Nachricht senden

1

23.01.2010, 14:20

Windows zu Grub2 hinzufügen (keine menu.lst)

HAllo, bei mir existiert die DAtei "menu.lst" nicht, habe aber schon heraus gefunden, das das an Grub2 liegt und das man nun die "grub.cfg" editieren muss.

Mein System:

Kubuntu, openSuse, Windows Server

Die ersten zwei werden im Grub Bootmenü angezeigt und ich kann sie auch booten. Aber Windows wird nicht angezeigt. Welchen eintrag muss ich nun erstellen, damit Windows angezeigt wird und welche PArameter muss ich angeben damit es richtig bootet?

Ein sudo grub-mkconfig führt Windows nicht auf!!

BluePeril

Meister

Beiträge: 2 026

Rechnerkonfiguration: ATI Radeon 5770, 4096 MB RAM, MSI K9A2 CF, AMD Phenom II X2 550, Arch Linux (64bit), Windows 7 Professional (64bit)

  • Nachricht senden

2

23.01.2010, 15:11

Grub2 hat auch keine menu-lst mehr. Wird alles in der grub.cfg geregelt.
Um Windows starten zu können, muss folgender Eintrag rein (und eventuell an dein System angepasst werden):

Quellcode

1
2
3
4
menuentry "Windows" {
    set root=(hd0,1)
    chainloader +1
}

hd0,1 entspricht der ersten Partition auf der ersten Festplatte.

$@ncho

Schüler

  • »$@ncho« ist der Autor dieses Themas

Beiträge: 123

Rechnerkonfiguration: AMD 3500+ @4100+ 2GB Corsair RAM 400er Blue Orb Lüfter

  • Nachricht senden

3

24.01.2010, 17:14

Habe jetzt folgenden Eintrag:

echo "Adding Windows Server entry" >&2
cat << EOF
menuentry "Windows Server" {
insmod ntfs
set root=(hd1,1)
drivemap -s (hd1) ${root}
chainloader 1
}
EOF

und im Bootmenu ist der jetzt auch drinnen aber da kommt jetzt:

BOOTMGR fehlt
Neustart mit strg alt entf

Habe auch folgendes versucht

echo "Adding Windows 7 entry" >&2
cat << EOF
menuentry "Windows 7" {
insmod ntfs
set root=(hd1,1)
chainloader 1
}
EOF

aber selbes Problem

BluePeril

Meister

Beiträge: 2 026

Rechnerkonfiguration: ATI Radeon 5770, 4096 MB RAM, MSI K9A2 CF, AMD Phenom II X2 550, Arch Linux (64bit), Windows 7 Professional (64bit)

  • Nachricht senden

4

24.01.2010, 21:43

Wie sieht denn deine Aufteilung auf den / der Festplatte(n) aus? Damit wäre es einfacher zu helfen.

Wenn der folgende Text wirklich so in der grub.cfg drin steht, ist es sinnlos, denn hier stimmt einiges nicht.

Quellcode

1
2
3
4
5
6
7
8
echo "Adding Windows 7 entry" >&2
cat << EOF
menuentry "Windows 7" {
insmod ntfs
set root=(hd1,1)
chainloader +1
}
EOF

EOF ist End of file (Dateiende). Befehle wie "cat << EOF" oder "echo "Adding Windows 7 entry" >&2" haben in der grub.cfg auch nichts zu suchen.

Wie schon geschrieben, poste mal deine Aufteilung der Platten und dann ist es einfach zu helfen.

$@ncho

Schüler

  • »$@ncho« ist der Autor dieses Themas

Beiträge: 123

Rechnerkonfiguration: AMD 3500+ @4100+ 2GB Corsair RAM 400er Blue Orb Lüfter

  • Nachricht senden

5

26.01.2010, 09:44

da man die grub.cfg nicht edditieren kann (draf) ist dieser Text in einem Skript, in der grub.cfg steht nach grub-update, bei welchem das Skript ausgeführt wird folgendes Drinnen:

Quellcode

1
2
3
4
5
 menuentry "Windows 7" {
insmod ntfs
set root=(hd1,1)
chainloader +1
}

$@ncho

Schüler

  • »$@ncho« ist der Autor dieses Themas

Beiträge: 123

Rechnerkonfiguration: AMD 3500+ @4100+ 2GB Corsair RAM 400er Blue Orb Lüfter

  • Nachricht senden

6

29.01.2010, 15:10

Ok ich hab es geschafft...

Win neu installiert, Grub Rescue Disk, Kubunt gebootet, grub-update durchgeführt.. alles läuft!!

Danke an alle Antworten!!!

Verwendete Tags

Grub2, Windows

Bookmark and Share