Windows zu Grub2 hinzufügen (keine menu.lst)

    Windows zu Grub2 hinzufügen (keine menu.lst)

    HAllo, bei mir existiert die DAtei "menu.lst" nicht, habe aber schon heraus gefunden, das das an Grub2 liegt und das man nun die "grub.cfg" editieren muss.

    Mein System:

    Kubuntu, openSuse, Windows Server

    Die ersten zwei werden im Grub Bootmenü angezeigt und ich kann sie auch booten. Aber Windows wird nicht angezeigt. Welchen eintrag muss ich nun erstellen, damit Windows angezeigt wird und welche PArameter muss ich angeben damit es richtig bootet?

    Ein sudo grub-mkconfig führt Windows nicht auf!!
    Grub2 hat auch keine menu-lst mehr. Wird alles in der grub.cfg geregelt.
    Um Windows starten zu können, muss folgender Eintrag rein (und eventuell an dein System angepasst werden):

    Quellcode

    1. menuentry "Windows" {
    2. set root=(hd0,1)
    3. chainloader +1
    4. }

    hd0,1 entspricht der ersten Partition auf der ersten Festplatte.
    Habe jetzt folgenden Eintrag:

    echo "Adding Windows Server entry" >&2
    cat << EOF
    menuentry "Windows Server" {
    insmod ntfs
    set root=(hd1,1)
    drivemap -s (hd1) ${root}
    chainloader 1
    }
    EOF

    und im Bootmenu ist der jetzt auch drinnen aber da kommt jetzt:

    BOOTMGR fehlt
    Neustart mit strg alt entf

    Habe auch folgendes versucht

    echo "Adding Windows 7 entry" >&2
    cat << EOF
    menuentry "Windows 7" {
    insmod ntfs
    set root=(hd1,1)
    chainloader 1
    }
    EOF

    aber selbes Problem
    Wie sieht denn deine Aufteilung auf den / der Festplatte(n) aus? Damit wäre es einfacher zu helfen.

    Wenn der folgende Text wirklich so in der grub.cfg drin steht, ist es sinnlos, denn hier stimmt einiges nicht.

    Quellcode

    1. echo "Adding Windows 7 entry" >&2
    2. cat << EOF
    3. menuentry "Windows 7" {
    4. insmod ntfs
    5. set root=(hd1,1)
    6. chainloader +1
    7. }
    8. EOF

    EOF ist End of file (Dateiende). Befehle wie "cat << EOF" oder "echo "Adding Windows 7 entry" >&2" haben in der grub.cfg auch nichts zu suchen.

    Wie schon geschrieben, poste mal deine Aufteilung der Platten und dann ist es einfach zu helfen.